[Ns-developers] A problem about openflow controller

Lalith Suresh suresh.lalith at gmail.com
Tue Mar 6 08:23:26 PST 2012


On Tue, Mar 6, 2012 at 7:42 AM, 鄭力維 <z789512346 at gmail.com> wrote:
> Hi,
> I'm a ns-3 newcomer who want to use the openflow module in ns-3
>
> I have installed the ns-3 with openflow module and tried the example of
> openflow-switch in src/openflow/examples
>
> Then I want to make the openflow switch in ns-3 connect with a controller
> outside ns-3(Nox),
> but it always fails
>
> In my simulation environment, I use two VMs which OS are Ubuntu11.10(using
> VMware) , one is for running controller and the other is for running ns-3
> Two VMs connect with each other by using VMnet
> I'm sure that two VMs are connected (I can ping from VM1 to VM2 by using
> emu-ping in src/emu/example)
>
> About the openflow switch in my simulation, I use the OpenFlowSwitchHelper
> to install the openflow module on the switch
> by using Install(Ptr<Node>, NetDeviceContainer ) , and use the EmuNetDevice
> to bind it with a real network device(eth0)
>
> When I run the simulation, the switch in ns-3 does not connect with the
> controller( since the controller does not
> show the message that there is a connected switch)
>
> Do I wrong in any steps?
>

As far as I know, ns-3-openflow does not work with an external
controller. The best you an do is extend from ofi::Controller and
write one that'll run inside ns-3.

If you're interested in adding support to allow ns-3 openflow switches
to use an external controller, I'd be interested in reviewing/helping
out.

> Thanks



-- 
Lalith Suresh
www.lalith.in




More information about the Ns-developers mailing list